Problem
Unable to see other USJ Mailbox from myoffice.usj.edu (O365 Outlook) that you may have permission to view/access
Environment
USJ Faculty & Staff
Resolution
1. Log in to myoffice.usj.edu with your credentials
2. Click the icon with your initials or avatar in the top right corner.
3. Click on View another mailbox
4. Type in the email address of the additional mailbox in the search field of the pop up box
5. Select the account from the list
The mailbox will open in a new tab in your browser.
Cause
Unlike the Outlook desktop application, Outlook365 does not display additional mailboxes in the left pane that you have been granted access to. Each mailbox needs to be opened separately following this procedure.