Unable to locate Blackboard course (Faculty)

Problem

Are you assigned to teach this semester or in an upcoming semester, and cannot locate your course in Blackboard?  Follow the steps below to locate your Blackboard course shell.

Environment

Blackboard/Faculty

Resolution

  1. Contact the Registrar's Office (registrar@usj.edu or 860-231-5225) to confirm that you are listed as the Instructor of Record with at least a 1% course load in Jenzabar.
  2. Confirm that you are logging in to http://bb.usj.edu with your USJ email address and email password.  
    • If you are a new faculty member and do not yet have USJ email, you will need to complete your system access form first.  Contact HR for assistance.
    • If you have USJ email and do not remember your password, visit http://mypassword.usj.edu to reset it.
  3. Make sure you are looking at the correct term.  Note that Fall courses will always be listed as one year ahead (i.e., a course beginning August 2020 will have a course ID ending in FA2021).
  4. Blackboard courses are created 42 days prior to the start of the term.  Be sure to check back within this time frame.
  5. If you have completed the above and do not yet see your courses, submit a ticket to the Service Desk.  

Cause

The process of creating Blackboard courses does not happen immediately when accounts are created.  Faculty will need to check within the timeframe listed above to locate their course, and will need to ensure they have completed all forms and are listed with the Registrar's Office as the instructor of record.

Faculty who had a previous role at the university (former students or staff, for example) may encounter some delays when being listed in Blackboard.  Please let the Service Desk know that you have a former role so they can ensure you are listed properly.

Details

Article ID: 90397
Created
Thu 10/24/19 3:56 PM
Modified
Thu 1/16/20 1:55 PM